Product FAQs

Ask a Question

Error 28001 - sa password complexity error when installing TAC Vista 5

Failed to create or configure database on SQL Server! ([17] SQL Server does not exist or access denied.)

Windows Event log reveals the following error:

Product: Microsoft SQL Server 2005 Express Edition -- Error 28001. The sa password must meet SQL Server password policy requirements. For strong password guidelines, see Authentication Mode, in SQL Server Books Online.

Cause:

When installing TAC Vista 5 on a 2003 Server you can get an error if the group policy require a certain complexity on the sa password.

Resolution:


 

  1. One possibility is to edit the group policy
    1. Go to Start > Run and type gpedit.msc
    2. In the Local Group Policy Editor, navigate to Local Computer Policy > Computer Configuration > Windows Settings > Security Settings > Account Policies > Password Policy
    3. Set Password must meet complexity requirements to Disabled.


       
  2. The other option is to install the SQL 2005 Express SP3 yourself. It is downloadable from Microsoft.
    1. Remove the checkmark in "Hide Advanced Configuration"
    2. Set the instance to TACVISTA.
    3. Use the "custom" option in TAC Vista Server setup, and select the local SQL server.

 

Was this helpful?
What can we do to improve the information ?